tlstunnel/debian/rules

14 lines
313 B
Makefile
Executable File

#!/usr/bin/make -f
GO_LDFLAGS += -X 'main.configPath=/etc/tlstunnel'
GO_LDFLAGS += -X 'main.certDataPath=/var/lib/tlstunnel'
%:
dh $@ --builddirectory=_build --buildsystem=golang --with=golang
execute_before_dh_auto_build:
make tlstunnel.1
override_dh_auto_build:
dh_auto_build -- -ldflags "$(GO_LDFLAGS)"